bannerColor WARNING_YELLOW templateName poodleSSLVulnerability

Share count not showing on share button

33 posts / 0 new
Last post
Gareth Hughes's picture
Joined: 2011-08-10
Sep 21, 2011
Share count not showing on share button

I've added the LinkedIn share button to my wordpress site along with the Facebook, Google+ and Tweet buttons.

My site: http://www.geneticdigital.co.uk

All buttons work except LinkedIn which refuses to show the share count. That's to say, the counter displays but only displays the 'in' icon as oppose to an actual count.

If I share to my own LinkedIn profile I get a confirmation saying 'You have successfully shared this link.' and the counter changes to 1 but when I refresh the page the count is back to zero (the icon).

I've got no idea what it could be. Can anyone help?

The share button in the header is site wide and shares the root url. The share button at the bottom of each page/post shares the respective page/post url.

Any help appreciated.

Jeremy Johnstone's picture
Joined: 2011-04-17
Sep 22, 2011

The reason it doesn't show when you refresh the page is because the increment was done client side. Your actual share takes approximately 5-10min to get updated across all the caches. That said, if you came back later in the day, it should reflect the correct count. Is that not the case?

Gareth Hughes's picture
Joined: 2011-08-10
Sep 23, 2011

It is not the case Jeremy.

I should have been more specific and mentioned that the button has been in place for a couple of weeks. I waited till now to ask the question in case it took time (days perhaps) for the count to be reflected. As you mentioned, it should be 5-10mins but it is definitely not updating after that amount of time or considerably longer.

Thanks for helping.

Jeremy Johnstone's picture
Joined: 2011-04-17
Sep 23, 2011

Unfortunately, our error reporting leaves a bit to be desired, especially in this specific case. I will see if I can dig and find out what happened. It will likely be early next week before I have an answer, so please ping here again if I haven't updated by mid-week next week.

Gareth Hughes's picture
Joined: 2011-08-10
Sep 26, 2011

Thanks Jeremy, I'll keep checking back for updates. Appreciate it.

Gareth Hughes's picture
Joined: 2011-08-10
Sep 29, 2011

Strangely, the counter is now showing 1. However, it's definitely been shared by more than 1 LinkedIn user. So it's different, but still not right.

Gareth Hughes's picture
Joined: 2011-08-10
Oct 12, 2011

Hi Jeremy, have you had a chance to look at this again? Thanks.

Jeremy Johnstone's picture
Joined: 2011-04-17
Oct 12, 2011

Hi Gareth,

This is a bug on our side which the engineering team is working to resolve. Unfortunately, I don't have an ETA on when it will be resolved. My apologies for the inconvenience! :(

-Jeremy

Gareth Hughes's picture
Joined: 2011-08-10
Oct 12, 2011

No worries. At least I know it's not me :)

Thanks for letting me know.

Jeremy Johnstone's picture
Joined: 2011-04-17
Oct 12, 2011

Well, it sorta is your site, but it's not the only site which is causing problems. We are trying to track down what is causing things to fail on our end and once we do, we can provide guidance on what you can do in the short term while we push out a fix.

Joined: 2011-10-27
Nov 3, 2011

Hello.
We have the same problem with counters, but we use short url for sharing. In this case when we use short url the counters are wrong. Could you suggest some workarounds for this problem?
Sample, following both urls go to the same resource, but the counts are differents:
http://www.linkedin.com/cws/share-count?url=http%3A%2F%2Fomaha.mindmixer.com%2Fgetting-around-omaha
http://www.linkedin.com/cws/share-count?url=http%3A%2F%2Fmnd.mx%2F5542

Thanks for any help!

Jeremy Johnstone's picture
Joined: 2011-04-17
Nov 3, 2011

There are multiple known issues with regards to share. I apologize, but I do not have an ETA on when they will be resolved.

-Jeremy

Joined: 2011-11-27
Nov 29, 2011

Hi Jeremy,

I recently added share buttons to my site and seem to be experiencing the same issue as Gareth. The website is: http://deepsoil.cee.illinois.edu. We have share buttons at the top of each page to share the root url (http://deepsoil.cee.illinois.edu). I have tried sharing it several times. I get the message that it was successful and it shows up on my profile, but when I return to the site (using my computer, a colleague's computer, etc), the counter isn't shown. Pressing it again increments it to 1, even though it has been shared previously. I know you mentioned you guys were working on it, but I thought I'd pass this along too for you to test.

Thanks,
Michael

Jeremy Johnstone's picture
Joined: 2011-04-17
Nov 29, 2011

Hi Michael,

I've reported your issue to the engineering team. I'll let you know as soon as I have a response.

Thanks!

-Jeremy

Oscar Siniscalchi's picture
Joined: 2011-12-07
Dec 7, 2011

Jeremy:
Has this bug been fixed yet? I am having the same problem in my site.
Thanks
Oscar

Jeremy Johnstone's picture
Joined: 2011-04-17
Dec 7, 2011

Hi Oscar,

No it has not, but your issue might be different. Please post a URL to your site so I can confirm.

-Jeremy

Oscar Siniscalchi's picture
Joined: 2011-12-07
Dec 8, 2011

Jeremy,
Thanks for your reply.
Here is a link to my page where you can see the counter issue
http://www.stacksocial.com/bundles/2
Thanks

Steven Citron-Pousty's picture
Joined: 2011-08-02
Dec 8, 2011

Hey Oscar:
Can you please copy and paste the relevant snippets of HTML code you are using in your page.
Thanks
Steve

Joined: 2011-09-27
Dec 12, 2011

Has this issue been fixed, I am having the same issue, does linkedIn share work in a intranet.

Jeremy Johnstone's picture
Joined: 2011-04-17
Dec 14, 2011

Hi Kavitha,

Our current share implementation needs to be able to access the shared item from the public internet, otherwise it won't be able to share anything outside the URL and your comment.

-Jeremy

Joined: 2012-01-11
Jan 11, 2012

Is there any way to get share count of multiple urls in one api call?

Steven Citron-Pousty's picture
Joined: 2011-08-02
Jan 19, 2012

Zain:
I am sorry, there is no supported way to get the count for a share (or multiple shares). I understand how that could be something you would want but we don't currently have it. I will pass your suggestion on to the engineering team.
Thanks
Steve

Paul Badke's picture
Joined: 2011-10-13
Jan 25, 2012

We're having a similar issue. When I go to the Share Button generator page (https://developer.linkedin.com/plugins/share-button) and put it any URLs from RandyGage.com, it shows there are multiple shares. However, the button on the website doesn't show anything but zero. An example would be: http://www.randygage.com/blog/be-rich-for-god/

If I refresh the page a few times, sometimes the counter is correct, but it's usually at zero.

Any idea if this is related or is there something else I can check?

Steven Citron-Pousty's picture
Joined: 2011-08-02
Jan 26, 2012

When I look at the page you are talking about I see 12 shares on my first load.
I do notice you are loading a lot of content on that page from a lot of different sources.
The rendering of the share plugin is to first render the button with a count of 0, then go fetch the number of shares, then update the number in the button. Based on the way browsers work, there is no guaranteed timing for when the query for the share number will fire during page rendering. This is all a long way to say that you may have to wait a while until you see the number on your page.

Paul Badke's picture
Joined: 2011-10-13
Jan 26, 2012

Thanks for following up. I should have updated this thread yesterday when I fixed the problem. It turned out to be an issue with the WordPress plugin Digg Digg -- not the LinkedIn button. Digg Digg was adding some addtoany.com JS to the page which was messing up the LinkedIn button.

Not sure if it was specifically with Digg Digg, or if there's some sort of issue with addtoany.com and the LinkedIn button.

Thanks again!

Jeremy Johnstone's picture
Joined: 2011-04-17
Jan 27, 2012

Thanks for the heads up Paul. We will investigate what they are doing that is causing negative side effects to our functionality and reach out to them / attempt to find a way to defensively prevent it.

Enjoy!

-Jeremy

Bob Phibbs, the Retail Doctor®'s picture
Joined: 2012-02-01
Feb 1, 2012

Yes the entire button is now gone and it is fairly important for me. Would appreciate an update as it is Feb. 1. I thought of deleting DiggDigg and adding Sharebar but concerned my 300+ previous posts will lose their counts - correct?

Jeremy Johnstone's picture
Joined: 2011-04-17
Feb 1, 2012

Hi Bob,

That shouldn't be an issue. We track share counts based on the URL, so as long as the URL doesn't change, the count will be the same. As there has been many reports of different share bar providers having issues lately, especially with LinkedIn's share button (through no fault / change of our own sadly), at this point I really am forced to recommend using our share button directly rather than a 3rd party bundled solution.

-Jeremy

-Jeremy

Valentin Florea's picture
Joined: 2012-01-19
Feb 7, 2012

Hi Jeremy,

You were saying that the share count is tracked based on the URL. Does your code consider a different URL if it has a # anchor hash tag?

I need this info cause I'm trying to have multiple share buttons on a single page (each share button referring to a different article). Each article has a different hash tag by which the user visiting the site is taken directly to the relevant article on the page.

So - in a nutshell - can I have multiple share buttons with working share counts on a single page with multiple hash tags?

Thank you,
valentin

Jeremy Johnstone's picture
Joined: 2011-04-17
Feb 7, 2012

Hi Valentin,

I believe so, but the only way to confirm is to test. Should be pretty simple to setup a test page and see if the results are like you expect.

-Jeremy

Valentin Florea's picture
Joined: 2012-01-19
Feb 8, 2012

Yes, you're right, I'm sorry.

Meanwhile I did test it, and indeed it worked.
Thank you.

Jeremy Johnstone's picture
Joined: 2011-04-17
Feb 9, 2012

Hi Valentin,

Thanks for the update. Was just about to test it myself. :)

Enjoy!

-Jeremy

Neal Schaffer's picture
Joined: 2011-09-13
May 10, 2012

I found this post on Google search because I am facing the same issue with the LinkedIn button on the Digg Digg plugin. Let me explain in detail:

Everything up until posts that were published on May 8 were working perfectly.

On May 9 the following posts were published, but only descriptions and no photos are being pulled in by LinkedIn:

http://windmillnetworking.com/2012/05/09/optimize-for-mobile-and-watch-your-social-media-presence-soar/
http://windmillnetworking.com/2012/05/09/word-of-mouth-social-media-marketing/

Then, on May 10 (today) the following posts were published, but neither photo nor title/decription are being pulled in by LinkedIn:

http://windmillnetworking.com/2012/05/10/time-to-write-off-your-company-blog/
http://windmillnetworking.com/2012/05/10/email-marketing-is-growing-up-leaving-batch-and-blast-behind/

Since the Digg Digg code hasn't changed, is there something at LinkedIn that has changed in the last 48 hours vis a vis how data is being pulled in? Hope you can be of help, because the LinkedIn Shares of my content are way down now!

Thanks!

- Neal